Rails 2.3.6+ Dependency Issues

This past Sunday, Rails 2.3.6 was released, and quickly followed by 2.3.7 and 2.3.8. One of the major changes in these new versions is to require a newer version of Rack, specifically 1.1.0, that is incompatible with Rails 2.3.5 and older. Due to the fairly complex ways in which Rubygems resolves dependencies, this can prevent your app from starting – in your local environment as well as when deployed on Heroku. If you’ve been affected by this issue, you would see this error message:

    Missing the Rails gem. Please `gem install -v= x.x.x`,
    update your RAILS_GEM_VERSION setting in config/environment.rb 
    for the Rails version you dohave installed, or 
    comment out RAILS_GEM_VERSION to use the latest 
    version installed.

We have written up a new docs page page with information detailing the issue, how to reproduce on your local machine, and how to resolve it.

More from the author

Browse the archives for news or all blogs Subscribe to the RSS feed for news or all blogs.