Rails 3 Beta 4 on Heroku

Heroku now supports Rails 3 beta 4 with Ruby 1.8.7. Make sure to push up to bamboo, and you should be all set!

As Rails 3 matures and gets closer to production a number of pieces continue to change. The beta 4 update introduced two significant changes to be aware of:

  • Require Ruby 1.8.7 > p249 or Ruby 1.9.2.
  • Require Bundler 0.9.26.

Heroku has updated to Ruby REE 1.8.7-2010.02 which incorporates the necessary patches for Rails 3. We will add support for 1.9.2 when the community releases the official release. In the meantime, developers interested in using Rails 3 on Heroku must use Ruby 1.8.7.

We have also updated to the latest stable release of Bundler: 0.9.26. We will continue to track the evolution of bundler through their 1.0 release. Due to thousands of applications that have already adopted bundler on Heroku, each update must be carefully tested to ensure that we don’t disrupt ongoing application operation.

Browse the blog archives or subscribe to the full-text feed.